Checks whether this FormatOptions is valid for a given spec.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- specTypeId
- Type: Autodesk.Revit.DB ForgeTypeId
Identifier of the spec.
Return Value
True if the FormatOptions is valid, false otherwise.Remarks
The FormatOptions is valid if UseDefault is true or if the unit in the FormatOptions is valid for the spec. See UnitUtils.IsValidUnit(ForgeTypeId, ForgeTypeId) and UnitUtils.GetValidUnits(ForgeTypeId) .
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId). |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |