IsValidForSpec Method


Checks whether this FormatOptions is valid for a given spec.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public bool IsValidForSpec(
	ForgeTypeId specTypeId
)
Visual Basic
Public Function IsValidForSpec ( _
	specTypeId As ForgeTypeId _
) As Boolean
Visual C++
public:
bool IsValidForSpec(
	ForgeTypeId^ specTypeId
)

Parameters

specTypeId
Type: Autodesk.Revit.DBForgeTypeId
Identifier of the spec.

Return Value

True if the FormatOptions is valid, false otherwise.

Remarks

The FormatOptions is valid if UseDefault is true or if the unit in the FormatOptions is valid for the spec. See UnitUtils.IsValidUnit(ForgeTypeId, ForgeTypeId) and UnitUtils.GetValidUnits(ForgeTypeId).

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId).
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also