IsValidForSpec Method


Format Options Is Valid For Spec Method

Checks whether this FormatOptions is valid for a given spec.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsValidForSpec(
	ForgeTypeId specTypeId
)

Parameters

specTypeId ForgeTypeId
Identifier of the spec.

Return Value

Boolean
True if the FormatOptions is valid, false otherwise.
Exceptions
Exception Condition
ArgumentException specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId).
ArgumentNullException A non-optional argument was null
Remarks
The FormatOptions is valid if UseDefault is true or if the unit in the FormatOptions is valid for the spec. See UnitUtils.IsValidUnit(ForgeTypeId, ForgeTypeId) and UnitUtils.GetValidUnits(ForgeTypeId) .
See Also