An enumerated type listing the possible statuses associated with a Transaction, TransactionGroup, or SubTransaction,
or the result of a particular method call on one of those objects.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Since:
2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Members
Member name | Description |
---|---|
Uninitialized | initial value, the transaction has not been started yet in this status |
Started | transaction has begun (until committed or rolled back) |
RolledBack | rolled back (aborted) |
Committed | simply committed, ended an empty transaction, flushed all, or undo is disabled |
Pending | returned from error handling that took over managing the transaction |
Error | error while committing or rolling back |
Proceed | while still in error handling (internal status) |