TransactionStatus Enumeration


Transaction Status Enumeration

An enumerated type listing the possible statuses associated with a Transaction, TransactionGroup, or SubTransaction, or the result of a particular method call on one of those objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum TransactionStatus
Members
Member name Value Description
Committed 3 simply committed, ended an empty transaction, flushed all, or undo is disabled
Error 5 error while committing or rolling back
Pending 4 returned from error handling that took over managing the transaction
Proceed 6 while still in error handling (internal status)
RolledBack 2 rolled back (aborted)
Started 1 transaction has begun (until committed or rolled back)
Uninitialized 0 initial value, the transaction has not been started yet in this status
See Also