Formats a number with units into a string.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- units
- Type: Autodesk.Revit.DB Units
The units formatting settings, typically obtained from Document.GetUnits() .
- specTypeId
- Type: Autodesk.Revit.DB ForgeTypeId
Identifier of the spec of the value to format.
- value
- Type: System Double
The value to format, in Revit's internal units.
- forEditing
- Type: System Boolean
True if the formatting should be modified as necessary so that the formatted string can be successfully parsed, for example by suppressing digit grouping. False if unmodified settings should be used, suitable for display only.
- formatValueOptions
- Type: Autodesk.Revit.DB FormatValueOptions
Additional formatting options.
Return Value
The formatted string.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId). -or- The given value for value is not finite -or- The unit in the FormatOptions in formatValueOptions is not a valid unit for specTypeId. See UnitUtils.IsValidUnit(ForgeTypeId, ForgeTypeId) and UnitUtils.GetValidUnits(ForgeTypeId). |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |