Format Method (Units, ForgeTypeId, Double, Boolean, FormatValueOptions)


Unit Format Utils Format(Units, Forge Type Id, Double, Boolean, Format Value Options) Method

Formats a number with units into a string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static string Format(
	Units units,
	ForgeTypeId specTypeId,
	double value,
	bool forEditing,
	FormatValueOptions formatValueOptions
)

Parameters

units Units
The units formatting settings, typically obtained from Document.GetUnits() .
specTypeId ForgeTypeId
Identifier of the spec of the value to format.
value Double
The value to format, in Revit's internal units.
forEditing Boolean
True if the formatting should be modified as necessary so that the formatted string can be successfully parsed, for example by suppressing digit grouping. False if unmodified settings should be used, suitable for display only.
formatValueOptions FormatValueOptions
Additional formatting options.

Return Value

String
The formatted string.
Exceptions
Exception Condition
ArgumentException specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId). -or- The given value for value is not finite -or- The unit in the FormatOptions in formatValueOptions is not a valid unit for specTypeId. See UnitUtils.IsValidUnit(ForgeTypeId, ForgeTypeId) and UnitUtils.GetValidUnits(ForgeTypeId).
ArgumentNullException A non-optional argument was null
See Also