Format Method (Units, ForgeTypeId, Double, Boolean, FormatValueOptions)


Formats a number with units into a string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public static string Format(
	Units units,
	ForgeTypeId specTypeId,
	double value,
	bool forEditing,
	FormatValueOptions formatValueOptions
)
Visual Basic
Public Shared Function Format ( _
	units As Units, _
	specTypeId As ForgeTypeId, _
	value As Double, _
	forEditing As Boolean, _
	formatValueOptions As FormatValueOptions _
) As String
Visual C++
public:
static String^ Format(
	Units^ units, 
	ForgeTypeId^ specTypeId, 
	double value, 
	bool forEditing, 
	FormatValueOptions^ formatValueOptions
)

Parameters

units
Type: Autodesk.Revit.DBUnits
The units formatting settings, typically obtained from Document.GetUnits().
specTypeId
Type: Autodesk.Revit.DBForgeTypeId
Identifier of the spec of the value to format.
value
Type: SystemDouble
The value to format, in Revit's internal units.
forEditing
Type: SystemBoolean
True if the formatting should be modified as necessary so that the formatted string can be successfully parsed, for example by suppressing digit grouping. False if unmodified settings should be used, suitable for display only.
formatValueOptions
Type: Autodesk.Revit.DBFormatValueOptions
Additional formatting options.

Return Value

The formatted string.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId). -or- The given value for value is not finite -or- The unit in the FormatOptions in formatValueOptions is not a valid unit for specTypeId. See UnitUtils.IsValidUnit(ForgeTypeId, ForgeTypeId) and UnitUtils.GetValidUnits(ForgeTypeId).
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also