Adds the provided list of references to the tag's list of references.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2022
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- referencesToTag
- Type: System.Collections.Generic IList Reference
Remarks
The references must pass the following requirements to be added:
- Must not be already tagged.
- Must be of the same category when TagMode is TM_ADDBY_CATEGORY.
- Must be taggable by this tag type.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The operation failed. Please verify that the references are all taggable and that they are not already tagged. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions InvalidOperationException | This type of tag does not support multiple references. |