Adds the provided list of references to the tag's list of references.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- referencesToTag
- Type: System.Collections.GenericIListReference
References to be tagged.
Remarks
The references must pass the following requirements to be added:
- Must not be already tagged.
- Must be of the same category when TagMode is TM_ADDBY_CATEGORY.
- Must be taggable by this tag type.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The operation failed. Please verify that the references are all taggable and that they are not already tagged. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | The IndependentTag object does not have a tag behavior. -or- This type of tag does not support multiple references. |