Independent |
Adds the provided list of references to the tag's list of references.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters

Exception | Condition |
---|---|
ArgumentException | The operation failed. Please verify that the references are all taggable and that they are not already tagged. -or- This type of tag does not support multiple references. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | The IndependentTag object does not have a tag behavior. -or- Modifying tag references for MRA owned tag from API is not allowed. |

The references must pass the following requirements to be added:
- Must not be owned by MRA element.
- Must not be already tagged.
- Must be of the same category when TagMode is TM_ADDBY_CATEGORY.
- Must be taggable by this tag type.
- For multiple references, the tag type must have this functionality supported in the UI.