Returns the bottom faces for this host object.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- hostObject
- Type: Autodesk.Revit.DB HostObject
The host object.
Return Value
An array of references to the faces which are at the bottom of this element.Remarks
This utility supports host objects whose bottom faces represent one of the boundaries of CompoundStructure (such as roofs, floors or ceilings).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | This host object does not support access to top or bottom faces. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |