Returns the bottom faces for this host object.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- hostObject
- Type: Autodesk.Revit.DBHostObject
The host object.
Return Value
An array of references to the faces which are at the bottom of this element.Remarks
This utility supports host objects whose bottom faces represent one of the boundaries of CompoundStructure (such as roofs, floors or ceilings).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | This host object does not support access to top or bottom faces. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |