Get all the ids of constructions applicable to the input massSubCategory
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- ccda
- Type: Autodesk.Revit.DB Document
The document.
- massSubCategoryId
- Type: Autodesk.Revit.DB ElementId
The ElementId of the mass subcategory.
Return Value
Returns a set of ElementIds that for the ConceptualConstructionTypes that are appropriate for the subcategory.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The mass sub-category is none of the OST_MassInteriorWall, OST_MassExteriorWall, OST_MassExteriorWallUnderground, OST_MassWallsAll, OST_MassRoof, OST_MassFloor, OST_MassSlab, OST_MassFloorsAll, OST_MassShade, OST_MassGlazing, OST_MassSkylights, OST_MassGlazingAll or OST_MassOpening. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |