GetAllConceptualConstructionsForCategory Method


Get all the ids of constructions applicable to the input massSubCategory

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public static ICollection<ElementId> GetAllConceptualConstructionsForCategory(
	Document ccda,
	ElementId massSubCategoryId
)
Visual Basic
Public Shared Function GetAllConceptualConstructionsForCategory ( _
	ccda As Document, _
	massSubCategoryId As ElementId _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetAllConceptualConstructionsForCategory(
	Document^ ccda, 
	ElementId^ massSubCategoryId
)

Parameters

ccda
Type: Autodesk.Revit.DBDocument
The document.
massSubCategoryId
Type: Autodesk.Revit.DBElementId
The ElementId of the mass subcategory.

Return Value

Returns a set of ElementIds that for the ConceptualConstructionTypes that are appropriate for the subcategory.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The mass sub-category is none of the OST_MassInteriorWall, OST_MassExteriorWall, OST_MassExteriorWallUnderground, OST_MassWallsAll, OST_MassRoof, OST_MassFloor, OST_MassSlab, OST_MassFloorsAll, OST_MassShade, OST_MassGlazing, OST_MassSkylights, OST_MassGlazingAll or OST_MassOpening.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also