Conceptual |
Get all the ids of constructions applicable to the input massSubCategory
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static ICollection<ElementId> GetAllConceptualConstructionsForCategory(
Document ccda,
ElementId massSubCategoryId
)
Parameters
Return Value
ICollection ElementIdReturns a set of ElementIds that for the ConceptualConstructionTypes that are appropriate for the subcategory.

Exception | Condition |
---|---|
ArgumentException | The mass sub-category is none of the OST_MassInteriorWall, OST_MassExteriorWall, OST_MassExteriorWallUnderground, OST_MassWallsAll, OST_MassRoof, OST_MassFloor, OST_MassSlab, OST_MassFloorsAll, OST_MassShade, OST_MassGlazing, OST_MassSkylights, OST_MassGlazingAll or OST_MassOpening. |
ArgumentNullException | A non-optional argument was null |