Creates a new instance of RebarReinforcementData, or a null reference ( Nothing in Visual Basic) if the operation fails.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- rebarId
- Type: Autodesk.Revit.DB ElementId
the Id of the rebar
- iEnd
- Type: System Int32
The end of rebar where the coupler stays. This should be 0 or 1
Return Value
Creates a new instance of RebarReinforcementDataExceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |