Create Method


Creates a new instance of RebarReinforcementData, or a null reference (Nothing in Visual Basic) if the operation fails.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public static RebarReinforcementData Create(
	ElementId rebarId,
	int iEnd
)
Visual Basic
Public Shared Function Create ( _
	rebarId As ElementId, _
	iEnd As Integer _
) As RebarReinforcementData
Visual C++
public:
static RebarReinforcementData^ Create(
	ElementId^ rebarId, 
	int iEnd
)

Parameters

rebarId
Type: Autodesk.Revit.DBElementId
the Id of the rebar
iEnd
Type: SystemInt32
The end of rebar where the coupler stays. This should be 0 or 1

Return Value

Creates a new instance of RebarReinforcementData

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also