Create Method


Rebar Reinforcement Data Create Method

Creates a new instance of RebarReinforcementData, or if the operation fails.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static RebarReinforcementData Create(
	ElementId rebarId,
	int iEnd
)

Parameters

rebarId ElementId
the Id of the rebar
iEnd Int32
The end of rebar where the coupler stays. This should be 0 or 1

Return Value

RebarReinforcementData
Creates a new instance of RebarReinforcementData
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also