remove a set of exist components from the Electrical System.
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- components
- Type: Autodesk.Revit.DB ElementSet
The components removed from the electrical system.
Remarks
If successful, all the components will remove from the system. Otherwise a null reference ( Nothing in Visual Basic) is removed. This method will only function with the Autodesk Revit MEP application.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | Thrown when the components parameter Value is a null reference ( Nothing in Visual Basic) . |
Autodesk.Revit.Exceptions InvalidOperationException | Thrown when the components cannot be removed from the system. |