RemoveFromCircuit Method


Electrical System Remove From Circuit Method

remove a set of exist components from the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void RemoveFromCircuit(
	ElementSet components
)

Parameters

components ElementSet
The components removed from the electrical system.
Exceptions
Exception Condition
ArgumentNullException Thrown when the components parameter Value is .
InvalidOperationException Thrown when the components cannot be removed from the system.
Remarks
If successful, all the components will remove from the system. Otherwise is removed. This method will only function with the Autodesk Revit MEP application.
See Also