RemoveFromCircuit Method


remove a set of exist components from the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void RemoveFromCircuit(
	ElementSet components
)
Visual Basic
Public Sub RemoveFromCircuit ( _
	components As ElementSet _
)
Visual C++
public:
void RemoveFromCircuit(
	ElementSet^ components
)

Parameters

components
Type: Autodesk.Revit.DBElementSet
The components removed from the electrical system.

Remarks

If successful, all the components will remove from the system. Otherwise a null reference (Nothing in Visual Basic) is removed. This method will only function with the Autodesk Revit MEP application.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException Thrown when the components parameter Value is a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsInvalidOperationException Thrown when the components cannot be removed from the system.

See Also