Creates a new analyzer.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document that contains the physical model of the building.
- options
- Type: Autodesk.Revit.DB.Analysis BuildingEnvelopeAnalyzerOptions
Options for the method analyzing the building elements for the building envelope.
Return Value
The created analyzer.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |