Create Method


Creates a new analyzer.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2015

Syntax

C#
public static BuildingEnvelopeAnalyzer Create(
	Document document,
	BuildingEnvelopeAnalyzerOptions options
)
Visual Basic
Public Shared Function Create ( _
	document As Document, _
	options As BuildingEnvelopeAnalyzerOptions _
) As BuildingEnvelopeAnalyzer
Visual C++
public:
static BuildingEnvelopeAnalyzer^ Create(
	Document^ document, 
	BuildingEnvelopeAnalyzerOptions^ options
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document that contains the physical model of the building.
options
Type: Autodesk.Revit.DB.AnalysisBuildingEnvelopeAnalyzerOptions
Options for the method analyzing the building elements for the building envelope.

Return Value

The created analyzer.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also