Building |
Creates a new analyzer.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static BuildingEnvelopeAnalyzer Create(
Document document,
BuildingEnvelopeAnalyzerOptions options
)
Parameters
- document Document
- The document that contains the physical model of the building.
- options BuildingEnvelopeAnalyzerOptions
- Options for the method analyzing the building elements for the building envelope.
Return Value
BuildingEnvelopeAnalyzerThe created analyzer.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |