Gets override settings assigned to a particular scan within a PointCloudInstance element.
Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- elementId
- Type: Autodesk.Revit.DB ElementId
Id of the overridden element.
- scanTag
- Type: System String
The tag identifying the particular scan within the PointCloudInstance element. Tags can be obtained from PointCloudInstance via method getScans.
- doc
- Type: Autodesk.Revit.DB Document
Document containing the overridden element.
Return Value
The override settings assigned to the scan, if present, or a default override settings if nothing was found.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Thrown when supplied scanTag is not empty while doc is NULL |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |