GetPointCloudScanOverrideSettings Method (ElementId, String, Document)


Gets override settings assigned to a particular scan within a PointCloudInstance element.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public PointCloudOverrideSettings GetPointCloudScanOverrideSettings(
	ElementId elementId,
	string scanTag,
	Document doc
)
Visual Basic
Public Function GetPointCloudScanOverrideSettings ( _
	elementId As ElementId, _
	scanTag As String, _
	doc As Document _
) As PointCloudOverrideSettings
Visual C++
public:
PointCloudOverrideSettings^ GetPointCloudScanOverrideSettings(
	ElementId^ elementId, 
	String^ scanTag, 
	Document^ doc
)

Parameters

elementId
Type: Autodesk.Revit.DBElementId
Id of the overridden element.
scanTag
Type: SystemString
The tag identifying the particular scan within the PointCloudInstance element. Tags can be obtained from PointCloudInstance via method getScans.
doc
Type: Autodesk.Revit.DBDocument
Document containing the overridden element.

Return Value

The override settings assigned to the scan, if present, or a default override settings if nothing was found.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException Thrown when supplied scanTag is not empty while doc is NULL
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also