Point |
Gets override settings assigned to a particular scan within a PointCloudInstance element.
Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public PointCloudOverrideSettings GetPointCloudScanOverrideSettings(
ElementId elementId,
string scanTag,
Document doc
)
Parameters
- elementId ElementId
- Id of the overridden element.
- scanTag String
- The tag identifying the particular scan within the PointCloudInstance element. Tags can be obtained from PointCloudInstance via method getScans.
- doc Document
- Document containing the overridden element.
Return Value
PointCloudOverrideSettingsThe override settings assigned to the scan, if present, or a default override settings if nothing was found.

Exception | Condition |
---|---|
ArgumentException | Thrown when supplied scanTag is not empty while doc is NULL |
ArgumentNullException | A non-optional argument was null |