Find Method


Finds the thermal properties by the 'id' property of a constructionType node in Constructions.xml.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2013

Syntax

C#
public static FamilyThermalProperties Find(
	Document pADoc,
	string constructionId
)
Visual Basic
Public Shared Function Find ( _
	pADoc As Document, _
	constructionId As String _
) As FamilyThermalProperties
Visual C++
public:
static FamilyThermalProperties^ Find(
	Document^ pADoc, 
	String^ constructionId
)

Parameters

pADoc
Type: Autodesk.Revit.DB Document
The document.
constructionId
Type: System String
The 'id' property of a constructionType node in Constructions.xml

Return Value

The thermal properties found, or a null reference ( Nothing in Visual Basic) if no match was found.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null

See Also