Create a spiral shape definition.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- doc
- Type: Autodesk.Revit.DB Document
- height
- Type: System Double
The height of the spiral (assuming the spiral is vertical).
- pitch
- Type: System Double
The pitch, or vertical distance traveled in one rotation.
- baseFinishingTurns
- Type: System Int32
The number of finishing turns at the lower end of the spiral.
- topFinishingTurns
- Type: System Int32
The number of finishing turns at the upper end of the spiral.
Remarks
In order to create a spiral definition, you must provide default values for the spiral-specific parameters. Replaces RebarShape.NewDefinitionByArc() from prior versions.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | baseFinishingTurns is not between 0 and 100. -or- topFinishingTurns is not between 0 and 100. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | The given value for height must be greater than 0 and no more than 30000 feet. -or- The given value for pitch must be greater than 0 and no more than 30000 feet. |