RebarShapeDefinitionByArc Constructor (Document, Double, Double, Int32, Int32)


Create a spiral shape definition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public RebarShapeDefinitionByArc(
	Document doc,
	double height,
	double pitch,
	int baseFinishingTurns,
	int topFinishingTurns
)
Visual Basic
Public Sub New ( _
	doc As Document, _
	height As Double, _
	pitch As Double, _
	baseFinishingTurns As Integer, _
	topFinishingTurns As Integer _
)
Visual C++
public:
RebarShapeDefinitionByArc(
	Document^ doc, 
	double height, 
	double pitch, 
	int baseFinishingTurns, 
	int topFinishingTurns
)

Parameters

doc
Type: Autodesk.Revit.DBDocument
height
Type: SystemDouble
The height of the spiral (assuming the spiral is vertical).
pitch
Type: SystemDouble
The pitch, or vertical distance traveled in one rotation.
baseFinishingTurns
Type: SystemInt32
The number of finishing turns at the lower end of the spiral.
topFinishingTurns
Type: SystemInt32
The number of finishing turns at the upper end of the spiral.

Remarks

In order to create a spiral definition, you must provide default values for the spiral-specific parameters. Replaces RebarShape.NewDefinitionByArc() from prior versions.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException baseFinishingTurns is not between 0 and 100. -or- topFinishingTurns is not between 0 and 100.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException The given value for height must be greater than 0 and no more than 30000 feet. -or- The given value for pitch must be greater than 0 and no more than 30000 feet.

See Also