RebarShapeDefinitionByArc Constructor (Document, Double, Double, Int32, Int32)


Rebar Shape Definition By Arc(Document, Double, Double, Int 32, Int 32) Constructor

Create a spiral shape definition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public RebarShapeDefinitionByArc(
	Document doc,
	double height,
	double pitch,
	int baseFinishingTurns,
	int topFinishingTurns
)

Parameters

doc Document
height Double
The height of the spiral (assuming the spiral is vertical).
pitch Double
The pitch, or vertical distance traveled in one rotation.
baseFinishingTurns Int32
The number of finishing turns at the lower end of the spiral.
topFinishingTurns Int32
The number of finishing turns at the upper end of the spiral.
Exceptions
Exception Condition
ArgumentException baseFinishingTurns is not between 0 and 100. -or- topFinishingTurns is not between 0 and 100.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException The given value for height must be greater than 0 and no more than 30000 feet. -or- The given value for pitch must be greater than 0 and no more than 30000 feet.
Remarks
In order to create a spiral definition, you must provide default values for the spiral-specific parameters. Replaces RebarShape.NewDefinitionByArc() from prior versions.
See Also