Looks up an existing fabrication part type based on a specfic fabrication service button and condition.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document.
- button
- Type: Autodesk.Revit.DB FabricationServiceButton
The fabrication service button.
- condition
- Type: System Int32
The condition index.
Return Value
Identifier of the fabrication part type element or invalidElementId if no fabrication part type exist for the specific fabrication service button and conditionExceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | the index condition is not larger or equal to 0 and less than ConditionCount |