Fabrication |
Looks up an existing fabrication part type based on a specfic fabrication service button and condition.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static ElementId Lookup(
Document document,
FabricationServiceButton button,
int condition
)
Parameters
- document Document
- The document.
- button FabricationServiceButton
- The fabrication service button.
- condition Int32
- The condition index.
Return Value
ElementIdIdentifier of the fabrication part type element or invalidElementId if no fabrication part type exist for the specific fabrication service button and condition

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | The index condition is not larger or equal to 0 and less than ConditionCount. |