Lookup Method


Looks up an existing fabrication part type based on a specfic fabrication service button and condition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2016

Syntax

C#
public static ElementId Lookup(
	Document document,
	FabricationServiceButton button,
	int condition
)
Visual Basic
Public Shared Function Lookup ( _
	document As Document, _
	button As FabricationServiceButton, _
	condition As Integer _
) As ElementId
Visual C++
public:
static ElementId^ Lookup(
	Document^ document, 
	FabricationServiceButton^ button, 
	int condition
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document.
button
Type: Autodesk.Revit.DBFabricationServiceButton
The fabrication service button.
condition
Type: SystemInt32
The condition index.

Return Value

Identifier of the fabrication part type element or invalidElementId if no fabrication part type exist for the specific fabrication service button and condition

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException The index condition is not larger or equal to 0 and less than ConditionCount.

See Also