Assigns override settings associated with a DirectContext3D handle instance or type.
Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- aDoc
- Type: Autodesk.Revit.DB Document
Document where elementId resides.
- elementId
- Type: Autodesk.Revit.DB ElementId
Id of the element to be overridden.
- newSettings
- Type: Autodesk.Revit.DB.DirectContext3D DirectContext3DHandleSettings
The override settings to be assigned to the handle element.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The ElementId elementId is not a valid DirectContext3D handle instance or type. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |