SetDirectContext3DHandleSettings Method


Assigns override settings associated with a DirectContext3D handle instance or type.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2018

Syntax

C#
public void SetDirectContext3DHandleSettings(
	Document aDoc,
	ElementId elementId,
	DirectContext3DHandleSettings newSettings
)
Visual Basic
Public Sub SetDirectContext3DHandleSettings ( _
	aDoc As Document, _
	elementId As ElementId, _
	newSettings As DirectContext3DHandleSettings _
)
Visual C++
public:
void SetDirectContext3DHandleSettings(
	Document^ aDoc, 
	ElementId^ elementId, 
	DirectContext3DHandleSettings^ newSettings
)

Parameters

aDoc
Type: Autodesk.Revit.DBDocument
Document where elementId resides.
elementId
Type: Autodesk.Revit.DBElementId
Id of the element to be overridden.
newSettings
Type: Autodesk.Revit.DB.DirectContext3DDirectContext3DHandleSettings
The override settings to be assigned to the handle element.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The ElementId elementId is not a valid DirectContext3D handle instance or type.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also