SetDirectContext3DHandleSettings Method


Direct Context 3DHandle Overrides Set Direct Context 3DHandle Settings Method

Assigns override settings associated with a DirectContext3D handle instance or type.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetDirectContext3DHandleSettings(
	Document aDoc,
	ElementId elementId,
	DirectContext3DHandleSettings newSettings
)

Parameters

aDoc Document
Document where elementId resides.
elementId ElementId
Id of the element to be overridden.
newSettings DirectContext3DHandleSettings
The override settings to be assigned to the handle element.
Exceptions
Exception Condition
ArgumentException The ElementId elementId is not a valid DirectContext3D handle instance or type.
ArgumentNullException A non-optional argument was null
See Also