Sets an aspect of the material to a shared property set.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- aspect
- Type: Autodesk.Revit.DB MaterialAspect
The material aspect.
- propertySetId
- Type: Autodesk.Revit.DB ElementId
Identifier of a shared property set (an instance of PropertySetElement).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |