SetMaterialAspectByPropertySet Method


Sets an aspect of the material to a shared property set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetMaterialAspectByPropertySet(
	MaterialAspect aspect,
	ElementId propertySetId
)
Visual Basic
Public Sub SetMaterialAspectByPropertySet ( _
	aspect As MaterialAspect, _
	propertySetId As ElementId _
)
Visual C++
public:
void SetMaterialAspectByPropertySet(
	MaterialAspect aspect, 
	ElementId^ propertySetId
)

Parameters

aspect
Type: Autodesk.Revit.DBMaterialAspect
The material aspect.
propertySetId
Type: Autodesk.Revit.DBElementId
Identifier of a shared property set (an instance of PropertySetElement).

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also