SetMaterialAspectByPropertySet Method


Material Set Material Aspect By Property Set Method

Sets an aspect of the material to a shared property set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetMaterialAspectByPropertySet(
	MaterialAspect aspect,
	ElementId propertySetId
)

Parameters

aspect MaterialAspect
The material aspect.
propertySetId ElementId
Identifier of a shared property set (an instance of PropertySetElement).
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also