Gets Placement Adaptive Point Element Ref ids to which the instance geometry adapts.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- famInst
- Type: Autodesk.Revit.DB FamilyInstance
The FamilyInstance.
Return Value
The Placement Adaptive Point Element Ref ids to which the instance geometry adapts.Remarks
The output contains placement point ref ids. The element ids are sorted in by the placement numbers (increasing order).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The FamilyInstance famInst is not an Adaptive Family Instance. -or- The FamilyInstance famInst does not have an Adaptive Family Symbol. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions InvalidOperationException | This operation failed. |