GetInstancePlacementPointElementRefIds Method


Gets Placement Adaptive Point Element Ref ids to which the instance geometry adapts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public static IList<ElementId> GetInstancePlacementPointElementRefIds(
	FamilyInstance famInst
)
Visual Basic
Public Shared Function GetInstancePlacementPointElementRefIds ( _
	famInst As FamilyInstance _
) As IList(Of ElementId)
Visual C++
public:
static IList<ElementId^>^ GetInstancePlacementPointElementRefIds(
	FamilyInstance^ famInst
)

Parameters

famInst
Type: Autodesk.Revit.DBFamilyInstance
The FamilyInstance.

Return Value

The Placement Adaptive Point Element Ref ids to which the instance geometry adapts.

Remarks

The output contains placement point ref ids. The element ids are sorted in by the placement numbers (increasing order).

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The FamilyInstance famInst is not an Adaptive Family Instance. -or- The FamilyInstance famInst does not have an Adaptive Family Symbol.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException This operation failed.

See Also