Adaptive |
Gets Placement Adaptive Point Element Ref ids to which the instance geometry adapts.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static IList<ElementId> GetInstancePlacementPointElementRefIds(
FamilyInstance famInst
)
Parameters
- famInst FamilyInstance
- The FamilyInstance.
Return Value
IList ElementIdThe Placement Adaptive Point Element Ref ids to which the instance geometry adapts.

Exception | Condition |
---|---|
ArgumentException | The FamilyInstance famInst is not an Adaptive Family Instance. -or- The FamilyInstance famInst does not have an Adaptive Family Symbol. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | This operation failed. |

The output contains placement point ref ids. The element ids are sorted in by the placement numbers (increasing order).