Retrieves a list of the parameters associated with all rules in the filter that are combined (using logical AND) with a FilterCategoryRule corresponding to single %categoryId%.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2020
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- categoryId
- Type: Autodesk.Revit.DB ElementId
The category for which parameters should be found.
Return Value
A set of parameter identifiers.Remarks
Note that in the case when InvalidElementId specified as input %categoryId% this function returns parameters common to all categories used by this ParameterFilterElement, i.e. it is equivalent to ParameterFilterElement.GetElementFilterParameters().
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |