Parameter |
Retrieves a list of the parameters associated with all rules in the filter that are combined (using logical AND) with a FilterCategoryRule corresponding to single %categoryId%.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- categoryId ElementId
- The category for which parameters should be found.
Return Value
ISet ElementIdA set of parameter identifiers.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

Note that in the case when InvalidElementId specified as input %categoryId% this function returns parameters common to all categories used by this ParameterFilterElement, i.e. it is equivalent to ParameterFilterElement.GetElementFilterParameters().