GetElementFilterParametersForCategory Method


Parameter Filter Element Get Element Filter Parameters For Category Method

Retrieves a list of the parameters associated with all rules in the filter that are combined (using logical AND) with a FilterCategoryRule corresponding to single %categoryId%.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ISet<ElementId> GetElementFilterParametersForCategory(
	ElementId categoryId
)

Parameters

categoryId ElementId
The category for which parameters should be found.

Return Value

ISet ElementId
A set of parameter identifiers.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
Note that in the case when InvalidElementId specified as input %categoryId% this function returns parameters common to all categories used by this ParameterFilterElement, i.e. it is equivalent to ParameterFilterElement.GetElementFilterParameters().
See Also