Sets the internal state of the exporter to process the geometry and properties of the input element.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- Elem
- Type: Autodesk.Revit.DB Element
The element.
- GRep
- Type: Autodesk.Revit.DB GeometryElement
The geometry of the element. Optional, can be a null reference ( Nothing in Visual Basic) .
Remarks
The element will be assigned until PopExportState() is called.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |