PushExportState Method


Sets the internal state of the exporter to process the geometry and properties of the input element.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public void PushExportState(
	Element Elem,
	GeometryElement GRep
)
Visual Basic
Public Sub PushExportState ( _
	Elem As Element, _
	GRep As GeometryElement _
)
Visual C++
public:
void PushExportState(
	Element^ Elem, 
	GeometryElement^ GRep
)

Parameters

Elem
Type: Autodesk.Revit.DBElement
The element.
GRep
Type: Autodesk.Revit.DBGeometryElement
The geometry of the element. Optional, can be a null reference (Nothing in Visual Basic).

Remarks

The element will be assigned until PopExportState() is called.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also