Creates a new container object which holds IfcCurve handles processed from a Revit geometry object.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- ExporterIFC
- Type: Autodesk.Revit.DB.IFC ExporterIFC
The exporter.
- lcs
- Type: Autodesk.Revit.DB Transform
The local coordinate system that defines the plane in which the curve handles must lie.
- projectionDir
- Type: Autodesk.Revit.DB XYZ
The normal vector to the input plane.
- planViewOnly
- Type: System Boolean
True to match curves with plan view visibility only, false to match curves regardless of their plan view visibility.
Return Value
The new geometry info container.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |